Diary

Spread the love

.:diary 2012:.

here you can find the current state of the project in detail… problems i’m fighting with…maybe only interesting for freaks…anyway….just read and fall asleep: 🙂

28.02.2012 17:58 finally it’s done … the new demo videos are online… i’ll add soon some more infos today i’m a bit in a hurry…

cheers…

24.02.2012 22:47 recorded demo videos today…and well alot of work somehow 😉 unforunately i couldn’t finish them today…:/
anyway i already recorded 17 minutes now and there is still one part left to record…
but this recording session showed me… the firmware works quite good … i didn’t had a crash or something and i was working with it over 6 hours…coolso i’ll continue next week… hopefully i can finish it then…

have a nice weekend…

23.02.2012 22:50 yes… looks good so far… i could finish the stuff i wanted to include and tested a bit with a camera to record a movie… it’s a bit hard to get a good result but anyway…

so maybe tomorrow i do some videos… let’s see…

21.02.2012 23:21 are you still with me ?
well almost 2 1/2 year no update… sorry for that…ultra303 is not dead as it looks like !

the problems which caused the delay was a) the all oled lcds died but b) the main problem was that i had problems with my 303… there was a loose connection which drove me mad… after i tried to fix it (and failed) 2 years ago i totally lost motivation to continue…

but after some distance from the project i recovered a bit and finally could fix the loose connection… ok almost some small thing is still not wrong but anyway that’s ok to continue…

well very at the beginning when i got my 303 a speaker fell down on my 303 and the mainboard got some heavy fractures… every time i thought i finally fixed it it started again… a real nightmare

anyway… i was working quite hard in the last days to get some stuff working and looks good so far… so i hope i can upload very soon some new preview videos…
so stay tuned again…

nice to see some ppl still visiting my page after that long time… i tracked the counter a bit in the last days…

03.09.2009 22:38 working on something new … stay tuned 🙂
08.07.2009 16:54 after a small break i recovered a bit from the shock that the first batch of lcd i tried did not work… i tried a few more now… all dead… bla
anyway… i’ve decided to try out another lcd… an older one…
and… ? #1 lives again:
as you can see the display doesn’t look as good as the old one… and it’s somehow far too slow… but anyway… i ordered today some new of course no oled displays…;)
even uploading of the firmware works so far… had to search my entire room where the isp uploader is … so theroretically i could code a bit on the firmware..hm let’s see
but somehow the 303 sounds strange…something is wrong there… maybe i’ll trace it down if i get the new lcd displays
20.06.2009 03:00 hm… tried to reactivate my ultra303 today on my tb… unforunately all my lcd displays died…and none of them worked … after 2 years… great ! what a luck i didn’t sell it so far..
so … oled displays look good as you can see on my page but do not last long… i really could puke…as you maybe know oled displays are quite expensive i bought a few of them …a nearly rip… for this project… really sad… invested quite alot time in this project… bla
17.08.2006 20:15 i was working a bit on my sharc dsp project … so far you are interested… have a look to the diary:

no worries… i’ll continue ultra303 soon 😉

03.08.2006 18:05 today i’ve got my new toy:

this is a fpga development board from celoxica…
well i’ve got this for free for my sharc synth project very nice… the special about this is not the development board itself… it’s more the software which is included… you can code this fpga via vhdl or verilog ok nothing really new… but ! with this one you can code your fpga in c !… that rules totally 😉

so you can imagine i have to take a small break from the ultra303 project… this rc10 development board is just too interesting…;)

31.07.2006 23:52 well after a small chillout on the couch last night i wasn’t really tired so i coded the replay mode… no heavy task ideal for a small night coding job… in this mode you can select the patterns by pressing the key and stuff…
the leds are flashing to the current note and up/down/accent/slide looks cool ;)i had a closer look today why the 303 runs out of sync when it synced by the midi clock… hm very odd… when i turn off led multiplexing it works so far… when it’s switched on it runs out of sync… that’s no good…
until now i could not figure out why this happens… the strange thing is… when don’t sync to midi clock just to the bpm count it works fine without problems… there is no big change between midi clock and bpm… just the timer setup is a bit different…
anyway i’ll have closer look later surely a smaller problem which i can solve later…
30.07.2006 22:00 coded the entire day today on the firmware…i did some really good steps… the prefs menu is now almost complete now… so next will be to receive the dumped patterns from a sequencer…
and number two lives ! 😉 i build up the second prototype for my other tb… switched it on and worked… fine fine …
29.07.2006 21:50 some additions to the prefs menu today… i added a pattern format for all patterns and a init to system defaults…beside this added some new points to the todo list…hm it’s getting longer and longer…bla

hm the first 90% of a programm is fun… the last 10% is a real pain in the ass… sometime i have the feeling i need round about 5 times more motivation to handle the last 10%… mostly totally boring to code…
but i’ve decided not to include new features from now on… sure i will include new feature but only features i will really need…

28.07.2006 20:10 i added the prefs menu today…and coded the pattern dump feature and it’s gui…a bit is left to code… but i checked it with a midi monitor and looks good so far…
25.07.2006 20:45 recoded the midi routine today… hm the midi routine was the first i did when i started this project…well was better to do this 😉
beside this i started to code the sysex routines for pattern sending,,, but not finished yet…
i had an idea today… maybe it’s a good idea that the firmware can output the sequenced data to midi out… means you can use your tb 303 as sequencer for another synth… or just to record it in cubase …
24.07.2006 21:30 no big steps today… just a bit of soldering… i build up a second prototype for my second tb … cables are missing anyway…and soldered the midi cables to the first tb… and tested a bit the midi syncing… uh i recognised the latency is 30 ms… that’s of course too much… i remember i changed the eeprom timing a bit maybe a bit too much 😉
i will implement the midi stuff in the next time… means online editor reading and writing … pattern dump etc. i played a bit with the online editor hm a bit outdated i really have to code a bit on it … hm beside the rebirth reader i will include a audio realism bassline pattern reader… maybe a good idea…
22.07.2006 23:15 today was a good coding day… i added some custom lcd letters to the pitch mode for up down accent and slide to save some space on the lcd display… i think this looks better now before it was a bit hard to recognise what is the note efx and bla… just for a better overview…

finally i included the led multiplexing for the tb… (yes i was shifting this like always… last time i included it for the ml 303) but works fine so far… but still absolutly boring to code this… i really had to force myself to do this…

i’m really happy i ordered that prototypes…it seems it’s the final version of the pcb… so now i can concentrate to finish the firmware itself…

i will do soon a new video of my firmware with the tb 303 to show the new features… when i build up another prototype for my second tb 303… maybe i can do a video with two tb’s running in real time editing synced to a sequencer… hm never tried this… but i doubt it will sound great hm anyway

time for a backup … cheers !

21.07.2006 19:52 i tested a bit the new prototype today… works great… have a look the news section… i did a small groove sound demo…
18.07.2006 22:15 hm well… today was something like a perfect day… first i was at the beach enjoyed the great weather… when i came back from the beach i found on my desktop at work a packet…inside i found this:

these are my very first real pcbs … cooool 😉

so after some time at work i went home to solder … finally it looked like this:

ok not fully build up i didn’t soldered in the dac stuff… anyway … so hm will it work ? can i upload the firmware? hm when i tried to connect to the cpu… arf „time out error” hm slowly a nightmare started… i already considered with the thought fuck it still don’t work… hm i started to check the voltage… hm there was no…hm maybe a short circuit…

hmm but in the end … hm lol 😉 in the excitement i forgot to switch on the tb 303 … so no wonder i couldn’t connect to the cpu … hell i’m a noob 😉

anyway after i switched on the tb 303 it was just like how it should be… uploaded the current firmware… reset and all was working fine…

next cool thing is… because of the smd and the new connector to the tb 303 it fits just perfect into the tb 303 now without problems…

the only annoying thing was… it took 2 weeks to get the pcbs… bla… pcbpool sent the pcb to a wrong adress…

so after this perfect day… it’s time for a good beer…

cheers!

07.07.2006 17:33 the componets for the new pcb arrived yesterday… so i only need the pcbs 😉 today i checked the pcb tracking and it now turned from „technical check” to „in production” … that’s good
03.07.2006 18:46 i ordered the test pcbs a few seconds ago…so let’s see when they arrive… maybe at the end of the next week…
29.06.2006 18:46 i finished today the layout for the prototype for my pcb pool order…
i will check it again at weekend so maybe i will order them at monday…
28.06.2006 22:08 hm damn long break from this project… well after my failure on the new prototype i lost a bit interest in this project… and i’m still not 100% recovered from this…
hm i tried today to breath life into the new prototype…hm no chance i have no idea why i can’t upload my firmware to the cpu… the rs232 thing works … i tried it with another pcb… bla!the prototype itself works but upload don’t work… i checked now all i could check and decided to skip this prototype.. and i’ll create a new one… maybe the cpu has a problem dunno… to desolder it is nearly impossible because of smd and the thin tracks on the pcb… the pcb will surely be broken after it…

it’s damn hard to create this pcb here at home…and much of work… because of many vias and drills with 0,5 mm… and beside this the pcb is really small… one small mistake and the pcb is unusable…
this time i’ll order a prototype board from pcbpool… the minimum pcb must be 1 dm2 so i have to order a bit larger pcb…anyway advantage is of course i have 4 prototypes then…
maybe a better way to continue… and much more stressless…

20.03.2006 23:11 hm somehow i can’t upload the firmware to the new tb 303 prototype … hm very odd… i already checked it more than once but hm no idea why it doesn’t work…
15.03.2006 21:11 oki back to the tb 303 now… finished the prototype i started in december or better i redid… so far i could test it works fine… so i started to fit it into the 303… cutted the cables to the right length and it fits… that’s quite cool… there is round about 3 mm space to the switchboard…
next will be to implement the code i did for the ml 303 for the tb 303… a bit boring… but anyway
08.03.2006 23:55 again some smaller changes and bugfixes in the last days…tested a bit the midi firmware uploader… so far all is done and hopefully working for the first alpha version… i will send out today the pcb to the guy… let’s see if it works 😉
04.03.2006 20:29 today was a bugfixing day… removed even some major bugs… hm since some days i recognised a strange behavior of the firmware… some stuff were done by ghosthand… or other things went wrong…
today i could figure out why… hm just forgot to save a register during an interrupt…bla what a noob bug… hmm now i’m wondering how could this work 😉
so finally all is working really good and it’s time to send out the first version to an alpha tester…
28.02.2006 23:55 do you know this…? it’s always the same… shifting things since a year… things you aren’t very motivated to do… yes excatly this is what i’ve done with the led implementation of ultra303… yesterdays i could finally motivate me to do this… i added the led blinking and started to add to the entire firmware the led handling…
hm in the end it was just an hour of work… he unbelievable …would have been much less work to just to do it than to shift it since a year… anyway … but anyway the led stuff is only implemented for the ml 303 at the moment i still need to implement the new multiplexing for the tb… hm maybe i need to shift it another year !? ;))
25.02.2006 20:41 today was a good coding day…did some minor bugfixes and i continued that filter cv stuff means i added a filter sub menu to the user interface where you can setup the values for the lfos and envelopes… and i recognised during testing i will need something like patches for lfo and envelope… otherwise it’s a bit stressy when you have patterns with different lfo and envelope values… but at the moment i’m not sure about if the lfo and envelope value are saved with the pattern or should i save the values independent from the pattern…hm have to think a bit about it…filter envelop is working now… added lfo pattern syncing … what should i say ?

that lfo and env feature is cool… really funny to play with esp. that lfo pattern syncing is nice… you can sync the lfo to a note, 1/1 , 1/2, 1/4 and 1/16 pattern and stuff… or filter envelope attack is nice too… so you can provide some more advanced filter sweeps … sounds cool when you do not distort the 303 too much and creates more bleeps and bloobs somehow 😉

but at the moment the modulation of the envelope and lfo is always 100%… a bit too much sometimes… so next is to include the filter lfo and envelope modulation amount… at the moment is not possible to modulate for example the lfo with the envelope this is what i will next beside of the modulation amount… when all is working so far i will upload some demos of the new features… hm there is still a groove mp3 missing…

some stats of the source:

97 files
280 kb in all
27 kb object code… so enough space left to 64kb 😉

cheers!

22.02.2006 22:15 maybe you recognised… even for me 2006 started now… he 😉 forgot to change the date and mostly i copy and past the diary entries to create a new one… hm anyway

this week i soldered a bit … build up 4 of accenters distortion (http://beam.to/midi303) but the potis are missing to i can’t finish them now… i did also a second pcb of the new prototype for the ml…
and finally i did some code yesterday…well i’ve continued to implement the filter cv stuff… filter cv control is now working… means i can now modulate the filter via a lfo… filter envelope is from coding side done but not called at the moment… i was too tired yesterday to do that 😉
but looks like this is going to be a nice feature… but at the moment a bit hard to use… i did not add a possibility to change the values for filter lfo and filter envelope so i always need to change them in the source code… this is of course a bit annoying so next step will and must be a implementation for the user interface…
at the moment i added 2 lfo and 2 envelopes and they can modulate each other… maybe i will add some sync or ring mod for the filter lfo… well have to do some test if it sounds interesting otherwise i will skip it…

hm skipping…i’ve decided to skip the sid implementation… i’m slowly running out of memory… i just need memory esp. for stack and stuff… well since i’m using c i need of course more stack… hm and the sid implementation uses much of memory…it uses round about 50% of the low memory(stack is placed there too) to change it to xram will be too slow so it’s skipped… maybe i will do the sid stuff in an external cpu but not in the main cpu… same for the beatbox feature… but this one will be skipped totally…

16.02.2006 00:05 holy shit… on monday i included the filter velocity editor to include the filter cv stuff (already wrote a bit about that filter cv features scroll a bit down)…

well all was done very fast but while i was coding the filter cv control itself i recognised a bug… so since monday i was searching a bug in the firmware…and wasted 4 days… bla…
the bug produced an effect i could absolutly not explain… very strange… finally i found out i just accessed memory locations outside the available memory… even a read from that position forced the lcd to show totally crap…
i stripped down the entire firmware source…kicked off all unneeded stuff so in the end it was just a source of maybe 100 lines… damn much of work…and even with this 100 lines i could not trace down what the problem is… when i read from the $0800 mem this happens… when i read from $0200 it doesn’t happens… all access are going to the internal ram so no external bus i used (no ports are effected because of the mem access)…

in the end i come to this conclusion… this must be a strange behavoir of the cpu… i can’t see why a read to the mem produces such an effect…anyway
so the bug was just a *4 for a value…bla… however now i know about this problem and i can continue…but still annoying….

12.02.2006 11:18 i found the bug with the 4 switches now…of course again a routing bug from target…that tool sux..!
so far all is working fine 😉 i really hope i can motivate myself to do some code today… instead of sleeping on the couch 😉
09.02.2006 23:00 i could finish the new prototype yesterday… i switched it on and worked without a change… ok nearly 😉 4 switches don’t work… i will check later…
but it was real fun to build up this prototype… so i will do some more pcbs for my other ml 303 …when i located the switch problem…
that new plate to plate technic i figured out works really good…and it’s done fast… remembers a bit to sewing…but with this technic i’m even able to do plate to plate connections under smd pads… anyway i will post some fotos later how it works …
08.02.2006 23:25 i’m working the final prototype for the ml 303 ultra303 version…hm why again a new ml 303 prototype ? well i have much of ml 303’s and i slowy wanted to have a case for all…so i need a final version of it 😉
but looks really good so far… this time i guess i found good way to place the upper and lower layout for the pcb 100% excat… after etching i did some test drills and wow never had such a excat upper and lower pcb side layout… no displacement at all… i mean the plate to plate pads have a diameter of 0,8 mm (hole 0,5mm) and the hole is 100% inside of the pad…that’s pretty cool
the new prototype is based so far it was possible on smd parts only… that saved bit of pcb space… the pcb is now 105 cm2 instead of 131 cm2…that’s 20% smaller… and 110 holes less to drill
i had some days ago a new idea for a new plate to plate connection technic… before i just used rivets from bungard… but a) this is not working very good… b) needs too much time and c) stressy d) too expensive… so let’s see if this will work…

 

Komentarze są wyłączone.